HR Manager: Browser Configuration Error

To use HR Manager, your browser must meet the minimum requirements listed below. Please adjust your browser settings, then click here to try again.

DescriptionStatusDetails
Browser Type and VersionFailureGeneric crawler 2 is not compatible with HR Manager. Internet Explorer 9.0+ is the recommended browser, with Firefox 10.0+, Safari 5.0+ and Chrome 17.0+ also supported.
JavaScript EnabledFailureThis website requires JavaScript to be enabled in the browser.
AJAX supportFailureYour browser does not support AJAX, which is a requirement for the advanced functionality of HR Manager. Please try a browser that supports Ajax, such as Internet Explorer, Firefox, or Opera.
Mobile DevicePassYour browser supports Ajax.
Platform CheckWarningYour platform of Unknown has not been fully tested and may present usability issues and/or errors.